-ikiwiki (1.37) UNRELEASED; urgency=low
+ikiwiki (1.44) UNRELEASED; urgency=low
+
+ * Patch by Ben to fix validaton of atom feeds by fixing the category tags.
+ * Add a openidlogin-bg.gif to wikiicons and have the stylesheet use it for the
+ OpenID login form rather than linking to a remote logo, to avoid various
+ issues. Since there is not yet a license for the actual OpenID logo, this
+ file is currently a blank image. Users who want to can copy
+ http://openid.net/login-bg.gif into their wiki.
+ * Allow setting NOTAINT=1 when building the wiki to remove taint checking
+ flags, which can be useful on some hosting providers.
+ * Fix a bug that made links like [[0|foo]] use "foo" as the link text,
+ instead of "0".
+ * Changed calling convention for httmllink slightly. The first three
+ parameters remain the same, but additional options are now passed in using
+ named parameters.
+ * Change plugin interface version to 1.02 to reflect this change.
+ * Add a new anchor option to htmllink. Thanks Ben for the idea.
+ * Support anchors in wikilinks.
+ * Add a "more" plugin based on one contributed by Ben to allow implementing
+ those dreaded "Read more" links in blogs.
+ * Don't error out if estcmd fails, just print a warning message. estcmd is
+ too fragile to let it kill ikiwiki.
+ * Make img plugin not fail immediately if Image::Magick is not available.
+ This lets ikiwiki not build depend on perlmagic.
+ * Detect old versions of xgettext and avoid using them.
+ * perl is broken: print "" || die fails! Work around this insanity.
+ * Smarter detection of no-op changes to po files.
+ * Elegant patch from Ethan to clean up the display of page names in the
+ dropdown when creating a new page.
+ * Since the CGI had to drop the wiki lock to avoid deadlocking the
+ commit hook, it was possible for one CGI to race another one and "win"
+ the commit of both their files. This race has been fixed by adding a new
+ commitlock, which when locked by the CGI, disables the commit hook
+ (except for commit mails). The CGI then takes care of the updates the
+ commit hook would have done.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Feb 2007 03:35:52 -0500
+
+ikiwiki (1.43) unstable; urgency=low
+
+ * Allow plugins to add new types of tests that can be used in PageSpecs.
+ * Add a "conditional" plugin, which allows displaying text if a condition
+ is true. It is enabled by default so conditional can be used in the
+ basewiki.
+ * Use conditionals in the template for plugins, so that plugin pages
+ say if they're currently enabled or not, and in various other places
+ in the wiki.
+ * Updated Spanish translation.
+ * Make the basewiki be full of symlinks to pages that should be the same
+ in the doc wiki. This will allow direct edits to alter the base wiki
+ without manual munging.
+ * Fix the template, toggle, and conditional plugins to filter text before
+ preprocessing it.
+ * Fix smiley plugin to support smileys at the very beginning or end of
+ the content.
+ * Allow multiple tag settings to appear in a single page.
+ * Many changes to make ikiwiki very resistant to write failures
+ including out of disk space situations. ikiwiki should never leave
+ truncated files, and if the error occurs during a web-based file edit,
+ the user will be given an opportunity to retry.
+ Inspired by the many ways Moin Moin destroys itself when out of disk. :-)
+ * Fix syslogging of errors.
+ * Patch from Ethan to allow using meta tags to set creation dates of pages.
+ * Add a prettydate plugin that formats dates in a more readable fashion.
+ (I had to get a pretty date somehow today..)
+ * Updated Czech translation.
+ * Avoid potential syslog format string issue, although only older versions
+ of perl are vulnerable and it is not known to really be exploitable from
+ ikiwiki.
+ * Add explicit module prereqs to Makefile.PL
+ * New domain name for ikiwiki: ikiwiki.info. Update your links.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 18 Feb 2007 23:26:32 -0500
+
+ikiwiki (1.42) unstable; urgency=low
+
+ * Fix several more missing translations of Discussion.
+ * Fix for missing backlinks() in pagestats plugin.
+ * Add canedit hook, allowing arbitrary controls over when a page can be
+ edited.
+ * Move code forcing signing before edit to a new "signinedit" plugin, and
+ code checking for locked pages into a new "lockedit" plugin. Both are
+ enabled by default.
+ * Remove the anonok config setting. This is now implemented by a new
+ "anonok" plugin. Anyone with a wiki allowing anonymous edits should
+ change their configs to enable this new plugin.
+ * Add an opendiscussion plugin that allows anonymous users to edit
+ discussion pages, on a wiki that otherwise wouldn't allow it.
+ * Lots of CGI code reorg and cleanup.
+ * Avoid using lots of memory when copying large non-html files.
+ Yes, you can keep videos in the wiki..
+ * Add feedshow option to allow reducing the number of items included in
+ an rss or atom feed.
+ * Change based on a patch from Ethan to support relative matching in
+ PageSpecs, by using "./".
+ * pagespec_match() has grown a new third parameter to support this.
+ * Add "reverse" option to inline to invert sort orders.
+ * Drop the BSD license for the templates and basewiki, and just allow them
+ to be used as close to public domain as possible.
+ * viewcvs is now viewvc (in Debian unstable), update everything to use the
+ new name.
+ * Fix a security hole that allowed a web user to edit images and other
+ non-page format files in the wiki. To exploit this, the file already had
+ to exist in the wiki, and the web user would need to somehow use the web
+ based editor to replace it with malicious content.
+ (Sorry Josh, this means you can't edit style.css directly anymore,
+ although I do appreciate your fixes, actually..)
+
+ -- Joey Hess <joeyh@debian.org> Sat, 10 Feb 2007 15:37:39 -0500
+
+ikiwiki (1.41) unstable; urgency=low
+
+ * Gettext 1.04 or up is needed for the OO interface that ikiwiki needs,
+ if an older version is installed, just don't gettext strings, instead of
+ crashing.
+ * Added smileys for Moin Moin compatability.
+ * Fix handling of discussion links on discussion pages when l10n is used.
+ * Make gitorigin_branch and gitmaster_branch configurable via the setup
+ file. Closes: #408599
+ * French translation update. Closes: #408593
+ * Improve use of svn merge, by specifying the file to merge, rather than
+ chdiring to the srcdir (which wasn't right when merging in a subdir).
+ Thanks Ethan.
+ * Always call rcs_update after a commit during a web edit, to work around
+ the problem described in bugs/svn_fails_to_update. Thanks to Ethan for the
+ analysis and patch.
+ * Replace underscores in shortcut texts with spaces when formatting for
+ display. This allows using a shortcut like [[wikipedia War_of_1812]],
+ which links to the correct remote page, but is displayed nicely.
+ * When building the doc wiki, build with LANG=C.
+ * More gettext fun.
+ * Fix openid signin secret generation code. This fixes the bug that made
+ all openid signins fail the first time, and then succeed the second
+ time.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 30 Jan 2007 02:36:53 -0500
+
+ikiwiki (1.40) unstable; urgency=low
+
+ * Fix missing categories in rss/atom feeds.
+ * Add French translation by Jean-Luc Coulon. Closes: #406881
+ * Fix bogus use of CDATA in atom feeds. Closes: #406898
+
+ -- Joey Hess <joeyh@debian.org> Sun, 14 Jan 2007 21:42:27 -0500
+
+ikiwiki (1.39) unstable; urgency=low
+
+ * Add a rawhtml plugin that allows copying raw html files from the srcdir.
+ * Fix --locale to control LC_ALL now.
+ * Include the pot file in the source tarball. Closes: #405890
+ * Add a Swedish translation by Daniel Nylander. Closes: #406410
+ * Add a Czech translation by Miroslav Kure.
+ * Add a Bulgarian translation by Damyan Ivanov. Closes: #406580
+ * Add a Gujarati translation by Kartik Mistry. Closes: #406635
+ * Add a Vietnamese translation by Clytie Siddall.
+ * Fix encoding issue with use of Locale::Gettext. Seems that the OO
+ interface returns proper utf-8 decoded strings, unlike the traditional
+ interface, so use the OO interface.
+ * Search in default location for templates as a fallback when templatedir is
+ pointed elsewhere, so that only modified templates need to be copied into
+ a templatedir. Based on work by JeremyReed.
+ * In the aggregator, check for and deal with post filenames that are
+ longer than the maximum file length.
+ * Change the RecentChanges page to show the path of changed pages.
+ * Various minor bugfixes.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 13 Jan 2007 23:30:20 -0500
+
+ikiwiki (1.38) unstable; urgency=low
+
+ * Corrected a bum regexp in openid munging.
+ * Added a Spanish translation by Victor Moral.
+ * A few translation infrastructure fixes.
+ * Added a Polish translation by Paweł Tęcza.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 5 Jan 2007 23:13:59 -0500
+
+ikiwiki (1.37) unstable; urgency=low
* Add mirrorlist plugin.
* Fixed permissions of some files that were 600 in the tarball. (Did not
* Avoid creating edit links when the cgi url is not known.
* Avoid displaying discussion links at all, if there's not a discussion
page, when the cgi url isn't known.
- * svn was used as the RCS by default unless configured otherwise,
+ * Before, svn was used as the RCS by default unless configured otherwise,
now it defaults to using no RCS unless configured to do so, to avoid some
suprising behavior when using a setup file and not uncommenting any RCS
options.
-
- -- Joey Hess <joeyh@debian.org> Sat, 23 Dec 2006 01:51:49 -0500
+ * Fix some bugs in the commit email sending code.
+ * Improve code that ignores files in the underlaydir if the srcdir has a
+ file building the same page. Now it will work even if the extensions of
+ the source files differ.
+ * Initial work on internationalization of the program code. po/ikiwiki.pot
+ is available for translation.
+ * Export gettext() from IkiWiki module.
+ * Don't put discussion links on discussion pages.
+ * Allow disabling of plugins included in goodstuff.
+ * Add a textile format plugin contributed by mazirian.
+ * If a userdir is configured, links to pages in it can be made without
+ specifying the path. This allows for easy signing of comments by linking
+ to your page in the userdir.
+ * Escape slashes in page titles entered in the blog post form.
+ * Munge openids of the form somehost.com/user (trial, may revert).
+
+ -- Joey Hess <joeyh@debian.org> Sun, 31 Dec 2006 17:31:22 -0500
ikiwiki (1.36) unstable; urgency=low