- influence information when creating result objects.
- * Added `use_pagespec` function, that plugins can use to find a list
- of matching pages and add dependencies and influences, all at once,
- and efficiently.
- * Optimize away most expensive file prune calls, when refreshing,
+ influence information when creating result objects. This allows correctly
+ handling many more complicated dependencies.
+ * API change: `pagespec_match_list` has completly changed its interface.
+ The old interface will be removed soon, and a warning will be printed
+ if any plugins try to use it.
+ * Transitive dependencies are now correctly supported.
+ * ikiwiki-calendar: New command automates creation of archive pages
+ using the calendar plugin.
+ * calendar: Fix midnight rebuild trigger of calendars with explicit
+ month/year.
+ * calendar: Fix bug in next/previous year/month links, which sometimes
+ linked to an archive page from the wrong year, or were missing.
+ * git: --getctime will now follow renames back to the original creation
+ of a file.
+ * calendar: Fix CSS for year calendar to match the plugin documentation.
+ * Added minimal default CSS for calendar plugin, just highlighting the
+ current day.
+ * inline: Optimize generation of archives, etc by not getting inlined page
+ content if the template does not use it.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 17 Oct 2009 15:37:04 -0400
+
+ikiwiki (3.20091009) unstable; urgency=low
+
+ * parentlinks: Add has_parentlinks template parameter to allow styling
+ the toplevel index differently etc.
+ * img: Correct bug in image size calculation code.
+ * img: Fix dependency code for full size images.
+ * toggle, relativedate: Support templates that add attributes
+ to the body tag.
+ * Support RPC::XML 0.69's incompatible object instantiation method.
+ * mirrorlist: Display nothing if list is empty.
+ * Fix a bug that could lead to duplicate links being recorded
+ for tags.
+ * Optimize away most expensive file prune checks, when refreshing,