+ikiwiki (2.9) UNRELEASED; urgency=low
+
+ * Fix copyright and licence styling.
+ * tag: Add taglink preprocessor directive, supporting visible tag links.
+ Closes: #443344
+ * map: Fully specify paths to links to avoid issues when the bestlink
+ didn't point to the correct page.
+ * map: Render pages on the way to subpages whose parent pages
+ are not included in the map. Include special styling for such pages.
+ * map: Remove common prefixes and don't over-indent.
+ * Add class option to htmllink().
+ * img: Allow link=somepage to cause the image to link to a given page.
+ Slight overriding of link, as link=no is still used to disable the linking
+ entirely. Unless you have a page named "no"..
+ * Save index after previewing page edit, since even previewing can create
+ files in some situations, and this is appropriate in some cases, such as
+ the teximg plugin's error log file.
+ Such files will be automatically cleaned up at an appopriate later time.
+ * Don't allow whitespace in link text in a wikilink. This was still
+ allowed by the regexp in one case though not documented to work, and
+ was ambiguous with preprocessor directives.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 24 Sep 2007 12:48:35 -0400
+
+ikiwiki (2.8) unstable; urgency=low
+
+ * Redid the debian/copyright file, using the proposed new copyright file
+ format. Included many details not previously listed in the old file.
+ * inline: add feedonly option, set feedonly=yes to get only the feed button
+ but not inline the pages.
+ * meta: Support license and copyright information. The information will
+ be shown in the page footer. HTML will also be inserted that should
+ support the rel=license microformat as well as the HTML spec's
+ rel=copyright.
+ * table plugin: Actually specify the delimiter when parsing CSV.
+ * table plugin: The previous version broke WikiLinks inside quoted values.
+ Fix this by linkifying CSV data after parsing it, while DSV data is still
+ linkified before parsing.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 16 Sep 2007 20:02:25 -0400
+
+ikiwiki (2.7) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Add an editcontent hook.
+ * Support for looking in multiple directories for underlay files.
+ * Plugins can add new directories to the search path with the add_underlay
+ function.
+ * Split out smiley underlay files into a separate underlay, so if the plugin
+ isn't used, the wiki isn't bloated with all those files.
+ * Allow -cgi -wrapper to be passed on the command line to generate a
+ wrapper.
+ * Fix some taint issues with generating wrappers using the command line.
+ * Don't allow newlines in link text in a wikilink.
+ * Tables containing links with a link text were misparsed, because the "|"
+ in the wikilink looked like a table field separator. Avoid this ambiguity
+ by linkifying the data before parsing it as a table.
+ * Turn on allow_loose_quotes in the table plugin's Text::CSV object,
+ so that links from wikilinks don't confuse the parser.
+ * mercurial: Pass --style default to hg log to ensure right format is used.
+ * mercurial: Fix rcs_getctime (thanks, bma)
+
+ [ Josh Triplett ]
+ * Use git-log rather than the shell, git-rev-list, and git-diff-tree.
+ Patch by Jamey Sharp <jamey@minilop.net>.
+ * Renames from git-diff-tree aren't handled, so don't ask for them.
+ Patch by Jamey Sharp
+ * Handle operating in sub-trees of a git repository.
+ When looking for git commits that affect the wiki, only include changes
+ that affect the ikiwiki source directory. If that is not the top-level
+ directory in this git repository, strip off the prefix as given by
+ `git-rev-parse --show-prefix` from all names reported by git-log.
+ Patch by Jamey Sharp
+
+ [ Joey Hess ]
+ * Correct generation of RFC 3339 format times for atom/rss feeds. Always use
+ gmtime for these since a time zone is not specified.
+ * Updated Spanish translation from Victor Moral.
+ * table: Text::CSV doesn't return decoded unicode (XS module); decode its
+ return values.
+ * Change git test suite to reflect change in log for initial repo creation
+ commit.
+ * Add the ikiwiki-update-wikilist command.
+ * Exclude external plugin from syntax check since it uses a module that is
+ not in the build depends. Closes: #441171
+
+ -- Joey Hess <joeyh@debian.org> Sat, 08 Sep 2007 21:54:11 -0400
+
+ikiwiki (2.6.1) unstable; urgency=low
+
+ * Ye olde brown paper bag.
+ * Fix minor bug when blogging by cgi, introduced in last version.
+ * Fix a bug in unlockwiki intorduced last version that made it crash ikiwiki
+ if it wasn't locked when called. This is known to break post-commit
+ emails.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 26 Aug 2007 13:38:23 -0400
+
+ikiwiki (2.6) unstable; urgency=low
+
+ * Various minor bug fixes for silly mistakes in the code, thanks to the
+ various reviewers.
+ * Fix problems with previewing in the graphviz plugin. Thanks,
+ HenrikBrixAndersen.
+ * Allow raw html in the rst plugin.
+ * Add --set-option command line switch.
+ * pagetemplate: don't display template name
+ * Add rel=tag attribute to tag links, supporting that microformat, as well
+ as allowing them to be styled specially. Thanks, NicolasLimare.
+ * Add sessioncgi hook.
+ * Move blog form code out of CGI.pm and into the inline plugin.
+ * Updated Spanish translation from Victor Moral.
+ * Updated French translation from Cyril Brulebois. Closes: #437181
+ * The toc directive doesn't work well or make sense inside an inlined page.
+ Disable it when the page with the toc is nested inside another page.
+ * Apply a patch from NicolasLimare adding modification date tags to rss and
+ atom feeds, and also changing the publication time for a feed to the
+ newest modiciation time (was newest creation time).
+ * The patch also adds dcterms:creator to rss items that have a known author.
+ * Support pagespec "functions" with no parameters, like included() in the
+ conditional plugin.
+ * Add time=mtime option to postsparkline.
+ * Fix --libdir to work at the command line.
+ * Plugins can now be written as standalone external programs, which can
+ be written in any language that can do XML RPC.
+ * Change yet again how unhandled and escaped preprocessor directives are
+ re-output onto the page. Hopefully I finally got it right..
+ * Fix bug in deletion/move during edit code introduced in 1.44. Need to take
+ the underlaydir into account.
+ * Fix bug when editing file from underlaydir, need to rcs_add it even though
+ a page creation isn't occuring.
+ * Various minor fixes and stylistic improvements suggested by Perl::Critic.
+ * Applied Jeremie Koenig's pluggable editpage buttons patch:
+ - add a title to the editpage form;
+ - pass a reference to the list of buttons to the formbuilder_setup
+ hooks, so we can add ours;
+ - relax asumption about the possible submit values (use "Save Page"
+ explicitly);
+ - de-hardcode the submit buttons from the editpage template
+ (This was needed for compatability with a bug in CGI::FormBuilder
+ 3.0401, but ikiwiki already needs a newer version.)
+ * Pass buttons to all other formbuilder_setup hooks too.
+ * Add color parameter to postsparkline. Closes: #438900
+ * Add proper Homepage field to Debian package (needs uber-new dpkg).
+ * Add monotone support, contributed by William Uther.
+ * Avoid ugly gettext messages if LANG is empty. Closes: #439035
+ * Added teximg plugin to generate images from latex code.
+ Contributed by Patrick Winnertz as a GSoC project.
+ * Call the formbuilder hook for the edit page.
+ * Call decode_form_utf8 before running formbuilder_setup hooks.
+ * Add editdiff plugin contributed by Jeremie Koenig.
+ * Fix it to not leak path info.
+ * Add embed plugin, which allows embedding content from google maps, video,
+ calendar, and youtube. Normally, the htmlsanitiser eats these since they
+ use unsafe tags, the embed plugin overrides it for trusted sites.
+ * The googlecalendar plugin is now deprecated, and will be removed
+ eventually. Please switch to using the embed plugin.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 24 Aug 2007 17:09:44 -0400
+
+ikiwiki (2.5) unstable; urgency=low
+
+ * Wrap the editpage template in the standard misctemplate, this allows the
+ pagetemplate hook to work for that page.
+ * Above change fixes the favicon plugin to work on edit pages.
+ * Correct some issues with escaped preprocessor directives.
+ * Make the map plugin notice when pages in the map are deleted and update
+ it.
+ * Add a htmlext config option, this can be used to make ikiwiki generate
+ html files with a different extension.
+ * Fix graphviz plugin to not try to read images as utf-8; they might
+ sometimes contain invalid utf-8 byte sequences. Thanks,
+ HenrikBrixAndersen.
+ * Fix re-rendering of pages when a linked to page goes away. This was broken
+ in version 1.50 with the addition of %destsources. Thanks, Ethan
+ Glasser-Camp.
+ * Add templatefile hook.
+ * Add pagetemplate plugin, which allows changing the template used for
+ a page. (Not to be confused with the hook of the same name..)
+ * Add a libdir config option to let ikiwiki load perl modules, including
+ plugins, from a user-configurable directory.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 26 Jul 2007 21:42:43 -0400
+
+ikiwiki (2.4) unstable; urgency=low
+
+ * Make the toc plugin use html-compatible anchors. This is necessary since
+ most web sites serve ikiwiki xhtml files as text/html and mozilla browsers
+ get confused. So it's best for ikiwiki to follow the compatability
+ recommendations in appendix C of the XHTML spec. Closes: #432045
+ * Support building on systems that lack asprintf.
+ * mercurial getctime is currently broken, apparently by some change in
+ mercurial version 0.9.4. Turn the failing test case into a TODO test case.
+ * Fix links to alternate stylesheets when usedirs is enabled. Closes: #432556
+ * Use type= not style= in html for alternate stylesheets, which is more
+ correct (but in my testing both epiphany and iceweasel work ok with
+ style=text/css).
+ * In img tag, allow link=no to disable link to full size image. Thanks,
+ Nis Martensen. Closes: #433188
+
+ -- Joey Hess <joeyh@debian.org> Sun, 15 Jul 2007 15:02:43 -0400
+
+ikiwiki (2.3) unstable; urgency=low
+
+ * Corrected a typo in an error handler in the image plugin.
+ * Allow svnpath config option to contain additional extra slashes anywhere
+ w/o confusing ikiwiki.
+ * Rcs modules are now imported, so other modules that need similar
+ normalisation of configs etc can do so.
+ * Patch fixing various additional problems with test suite. Closes: #425891
+ once more.
+ * French update from Jean-Luc Coulon. Closes: #430771
+ * Correct a longstanding bug that could cause the edit form to be empty.
+ This turns out to have occured if the cgi wrapper was created by an
+ ikiwiki invocation that included --rebuild. Thanks to Carl Worth for
+ tracking that down.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 29 Jun 2007 18:30:38 -0400
+
+ikiwiki (2.2) unstable; urgency=low
+
+ * Change the aggregate plugin's locking strategy. Now it defers loading state
+ until the wiki is building and already locked, unless it's aggregating.
+ When aggregating, it does not wait for the lock if it cannot get it, and
+ instead exits, to prevent aggregating processes from piling up.
+ * Updated Spanish translation from Victor Moral.
+ * Correct bug in the img plugin that caused dependencies on images to not
+ always be tracked correctly.
+ * Deal better with rebuilds that involve moving files; track and clean up the
+ old files.
+ * Change where the img plugin puts scaled images. It's better to make the
+ scaled images subpages of the page that embeds them, rather than putting
+ them alongside the original image, since if two pages scale the same image
+ the same way, this prevents complications in dealing with two pages
+ creating the same file. The move will be handled transparently, though you
+ might want to rebuild your wiki to make it occur in one step.
+ * Fix FTBFS in test suite introduced in last version. Closes: #425891
+ * Apply a patch from Carl Worth allowing a class attribute to be passed
+ through the img plugin. Also allow the id attribute to be passed through.
+ * More consistent encoding of titles in rss and atom feeds. Don't use
+ ESCAPE=HTML for titles in the templates for these feeds, and instead
+ escape the title going in to the template. Previously, the title was
+ sometimes double-escaped in a feed (if set via meta title), and sometimes
+ not (if set from the page filename).
+ * In the meta plugin, when a title is set, encode the html entities in it
+ numerically. This works better in the current landscape of a rss spec that
+ doesn't specify encoding, and variously broken feed consumers, according
+ to <http://www.rssboard.org/rss-profile#data-types-characterdata>.
+ * Correct some issues with display of unhandled preprocessor directives.
+ * Apply a patch from Carl Worth adding support for using globs in link()
+ in a PageSpec.
+ * Explode some of the more insane regexps.
+ * Add test suite for preprocessor directive parsing.
+ * Fix wrapper generator and untaint code's handling of strings contining
+ newlines.
+ * Make the url absolution code for feeds significantly more robust.
+ * Add typographyattributes configuration setting to typography plugin.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 18 Jun 2007 21:21:56 +0100
+
+ikiwiki (2.1) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Use div layout for the signin and preferences forms, so that they can be
+ styled using the stylesheet, rather than by creating signin and prefs
+ templates.
+ * Make the openid login form nicely styled.
+ * Fix a bug that prevented clearing email or subscriptions.
+ * Improve handling of edits of locked pages by users who are not yet signed
+ in.
+ * Make testpagespec more robust, including checking for missing/bad
+ parameters.
+ * Add all=no option to conditional, can be used to form conditionals that do
+ not need to examine every page in the wiki.
+ * Add the needsbuild hook. Plugins can use this to manipulate which files
+ ikiwiki builds when refreshing the wiki.
+
+ [ Josh Triplett ]
+ * Add an account-creation password as a simple anti-spam mechanism. If
+ set in the wiki setup, passwordauth will require the password in
+ order to create an account.
+
+ [ Joey Hess ]
+ * Updated Czech translation from Miroslav Kure.
+ * Apply patch from Paweł Tęcza to avoid using -L in Makefile as it's not
+ available in older finds.
+ * Make all templates have a footer div to ease themeing. Required template
+ and style sheet updates, and unless you're using customised versions,
+ you'll want to rebuild wikis on upgrade to this version to avoid
+ inconsistencies.
+ * Allow WIKINAME to to used in footers, as an example of something to put
+ there.
+ * Patch from hb to fix the pagestats plugin, which was broken by a past
+ change to the backlinks() function.
+ * Fix some bugs in password handling:
+ - If the password is empty in preferences, don't clear the existing
+ password.
+ - Actually check the confirm password field, even if it's left empty.
+ * Add a destpage parameter to the filter hook.
+ * Fix links to smilies generated by the smiley plugin for inlined pages. The
+ old links were often wrong, but often still worked by accident.
+ * Add a test ensuring that the basewiki is self-contained and has no broken
+ links.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 19 May 2007 20:37:38 -0400
+
+ikiwiki (2.00) unstable; urgency=low
+
+ [ Josh Triplett ]
+ * Avoid using GNU extensions to cp during "make install", which did
+ not work on FreeBSD. Thanks to Henrik Brix Andersen for the patch.
+
+ [ Joey Hess ]
+ * Use fieldsets in the preferences form to group related options together.
+ Especially cleans up the ordering of the admin's preferences form.
+ * Use a fieldset to set off the openid entry from the rest of the login
+ form.
+ * Enable openid logins by default.
+ * Enable usedirs by default.
+
+ [ Josh Triplett ]
+ * fieldset support appeared in CGI::FormBuilder 3.05, so increase
+ version in Depends on libcgi-formbuilder-perl to 3.05
+
+ [ Joey Hess ]
+ * If Net::OpenID::Consumer is not available, the openid module will quietly
+ disable itself, this avoids needing a hard dependency on the perl module.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 30 Apr 2007 00:43:02 -0400
+
+ikiwiki (1.51) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Support setting svnpath to "" for wikis that are rooted at the top of
+ their svn repositories, with no trunk directory.
+ * Minor template improvements by Alessandro.
+ * In mercurial backend, untaint ipaddr when using it as the user for the
+ commit. Thanks, Alexander Wirt. Closes: #420428
+ * Fix aggregator to not warn when a feed contains no body content at all.
+ * Work around bug #420636 by, if XML::Parser crashes, running the feed
+ content though Encode::decode_utf8.
+
+ [ Josh Triplett ]
+ * Change basewiki CSS to not put a border around images used as links.
+
+ [ Joey Hess ]
+ * Move the footer div to enclose tags and links too.
+ * More style sheet updates, remove the hack that used the tags div to create
+ the footer border.
+ * Due to template changes and style sheet changes that depend on them,
+ wiki rebuilds are recommended on upgrade to this version.
+ * Avoid .svn directories when installing from svn checkout.
+ * Fix sending of commit mails when new pages are added via the web.
+ * Add user(name) to the PageSpec for commit subscriptions.
+ * pagespec_match() has changed to take named parameters, to better allow
+ for extended pagespecs. The old calling convention will still work for
+ back-compat for now.
+ * The calling convention for functions in the IkiWiki::PageSpec namespace
+ has changed so they are passed named parameters.
+ * Plugin interface version increased to 2.00 since I don't anticipate any
+ more interface changes before 2.0.
+ * Updated Gujarati translation from Kartik Mistry. Closes: #421198
+ * Make pagespec_match return an object that can be stringified to tell
+ the reason why the match failed or succeeded.
+ * Add testpagespec plugin, which might be useful to see why a pagespec isn't
+ working as desired.
+
+ [ Josh Triplett ]
+ * Fix bestlink to use pagecase for pages in userdir, to support pages
+ with non-lowercase filenames.
+
+ [ Joey Hess ]
+ * Include wikiname in syslogged messages.
+ * Updated Polish translation from Paweł Tęcza.
+ * Updated Czech translation from Miroslav Kure.
+ * Updated Spanish translation from Victor Moral.
+ * Apply patch from hb that uses the full path to a file when adding a file
+ using the mercurial backend. Not 100% sure why it failed w/o the full
+ path, but this still passes the test suite, and indeed, is how the test
+ suite calls hg add.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 29 Apr 2007 00:01:23 -0400
+
+ikiwiki (1.50) unstable; urgency=low
+
+ [ Josh Triplett ]
+ * Add a graphviz plugin.
+ * Suggests: graphviz
+ * Enhance helponformatting and related documentation to supply more
+ information about available preprocessor directives.
+ * Add myself as a co-maintainer, with Joey's approval.
+
+ [ Joey Hess ]
+ * Add support for PROFILE=1 to the Makefile, this turns on profiling of the
+ wiki build using Devel::Profiler (Dprof can't handle ikiwiki).
+ * Add a new %destsources hash, which maps between a destination file and
+ the source page used to create it, ie it's the reverse of %renderedfiles.
+ * Use %destsources in htmllink and urlto for 20-50% speedup. Thanks
+ Josh Triplett for the idea.
+ * Optimise displaytime, trimming maybe 6% off the build time.
+
+ [ Josh Triplett ]
+ * Conflicts/Replaces/Provides the unofficial ikiwiki-plugin-table
+ package, because ikiwiki now provides the table plugin, and thus has
+ a file overlap with ikiwiki-plugin-table.
+ * Add libtext-csv-perl to Suggests, for the table plugin.
+ * Add libdigest-sha1-perl to Suggests, for sparkline and graphviz.
+ * Add libtext-typography-perl to Suggests for the typography plugin.
+
+ [ Joey Hess ]
+ * Add postformtext parameter to inline.
+ * Internal version number and installdir substitutions were lost, fix.
+ * Apply patch from Ethan to improve an error message that should never
+ happen.
+ * Patch from Tuomov to link to the directory in feeds when usedirs is in
+ effect. Note that this changes permalinks, so if you are already using
+ usedirs you'll have to deal with that on upgrade to this version.
+ * Add feedshow parameter to inline, which can be useful for eg, removing
+ old posts from feeds when permalinks change.
+ * Add .dpkg-tmp to prune regexp, so that if ikiwiki is run right as it's
+ being upgraded by dpkg it will ignore dpkg temp files in the basewiki.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 15 Apr 2007 16:02:05 -0400
+
+ikiwiki (1.49) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Add --post-commit option, which allows for the case of a split web server
+ and RCS server (or a push mirror). With this the RCS server can have a
+ real post-commit hook that sshs back to the web server, and runs ikiwiki
+ in post-commit mode to update the wiki.
+ * Fix urls generated by mirrorlist plugin.
+ * Add a templates page to the basewiki. It will automatically list all
+ available templates. Rename the old templates page to wikitemplates.
+ * Include the note template in the basewiki.
+ * Add a popup template in the basewiki. CSS based on some by Martin Krafft.
+ * Make the note, popup, and plugin templates detect missing variables and be
+ self-documenting, listing the available variables.
+ * Hide excess backlinks and expand using CSS trick; control quantiy via
+ the numbacklinks setting.
+ * Finally apply the index.html patch, with thanks to everyone who worked
+ on and supported creating it (especially Tuomov). This adds a "usedirs"
+ option that makes ikiwiki use foo/index.html instead of foo.html as
+ output page names. It is not yet enabled by default.
+ * Fix a bug in the img plugin that caused thumbnailed files to not be
+ tracked properly.
+ * Make the OpenID library a reccommendation of the Debian package, rather
+ than just a suggests, since OpenID is enabled by default.
+ * Fix a bug that caused link(foo) to succeed if page foo did not exist.
+ * Fix tags to page names that contain special characters.
+
+ [ Josh Triplett ]
+ * Use pngcrush and optipng on all PNG files.
+ * Add neutral smileys ":|" and ":-|", and question icon smiley "(?)",
+ with images taken from phpBB (GPL) and converted with gif2png.
+ * Improvements to Description in debian/control:
+ * Note that some plugins have additional dependencies, found among the
+ Recommends and Suggests.
+ * ikiwiki supports both RSS and Atom feeds.
+ * Fix typos.
+ * Add Homepage field.
+ * Add XS-Vcs-Browser field.
+
+ [ Joey Hess ]
+ * Updated French translation from JLC. Closes: #417982
+ * Reorder the icon in the template above the stylesheets, to avoid icon
+ flashing during page load.
+ * Fix smiley plugin to scan smileys.mdwn after it's updated, which fixes
+ a bug caused by committing changes to smilies.mdwn.
+ * Fix display of escaped wikilinks containing anchors.
+
+ [ Josh Triplett ]
+ * Remove stray semicolon in linkmap.pm.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 08 Apr 2007 16:14:46 -0400
+
+ikiwiki (1.48) unstable; urgency=low
+
+ * Fix link() PageSpecs to not just look at the raw link text, but at where
+ that given link points based on the page doing the linking. Note that this
+ could make such PageSpecs match different things than before, if you
+ relied on the old behavior of them only matching the raw link text.
+ * This required changing the match_* interface, adding a third parameter.
+ * Allow link() PageSpecs to match relative, as is allowed with globs.
+ * Add postform option to inline plugin.
+ * Add an bug tracker to the softwaresite example.
+ * Make ikiwiki's stylesheet support printing by hiding parts of the page
+ that shouldn't appear in a printout: Search box, actions bar,
+ blog post form, tags, backlinks, and feed buttons.
+ * Finally fixed the longstanding inline removal bug.
+ * Renamed %oldpagemtime to a more accurately named %pagemtime and fix it to
+ actually store pages' mtimes.
+ * Add "mtime" sort parameter to inline plugin.
+ * Fix mercurial backend to deal with empty commit messages.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 24 Mar 2007 11:14:10 -0400
+
+ikiwiki (1.47) unstable; urgency=low
+
+ * Fix a security hole that allowed insertion of unsafe content via the meta
+ plugins's support for inserting html link and meta tags. Now such content
+ is passed through the htmlscrubber like everything else.
+ * Unfortunatly, that means that some valid uses of those tags are no longer
+ usable, and special case methods needed to be added for including
+ stylesheets, and for doing openid delegation. If you use either of these
+ in your wiki, it will need to be modified. See the meta plugin docs
+ for details.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Mar 2007 14:05:00 -0400
+
+ikiwiki (1.46) unstable; urgency=low
+
+ * Fix a bug with inlined create page links, including Discussion links on
+ blog post pages. The links will now create pages relative to the page that
+ actually contains the link.
+ * French update. Closes: #414597
+ * Fix some broken logic in cgi creation of a subpage when a toplevel page
+ with the same name already exists, and generally simplify the edit code.
+ * Make ikiwiki -verbose -setup with a setup file that enabled syslog logging
+ output the verbose build log to stdout, rather than to the syslog.
+ * Detect the case of two people independently creating the same page at the
+ same time, and let the second person resolve the conflict.
+ * Applied a patch from Michał to make the mercurial backend pass --quiet to
+ hg.
+ * Fix a security hole that allowed a web user to insert arbitrary html in
+ the title of a page due to missing escaping of titles in the meta plugin.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Mar 2007 01:51:30 -0400
+
+ikiwiki (1.45) unstable; urgency=low
+
+ * Allow for underscores to appear in page titles, if encoded appropriately
+ (__95__) in filenames. Previously, all underscores were replaced with
+ spaces. Thanks, Enrico Zini for noticing that bug.
+ * Add "template" option to inline plugin to allow for use of customised
+ templates.
+ * Add titlepage template for inline plugin.
+ * Add preview parameter to preprocesser calls, use this rather than the
+ previous ugly hack used to avoid writing rss feeds in previews.
+ * Fix the img plugin to avoid overwriting images in previews. Instead it
+ does all the work to make sure the resizing works, and dummys up a resized
+ image using width and height attributes.
+ * Also fixes img preview display, the links were wrong in preview before.
+ * Add a sparkline plugin.
+ * Add a postsparkline plugin.
+ * The slash escaping when adding to a blog from the CGI was not working
+ since it ended up being double-escaped. Instead, just remove slashes.
+ * Fix some nasty issues with page name escaping during previewing
+ (introduced in 1.44).
+ * Add a table plugin, derived from the one written by Victor Moral.
+ * The underscore escaping support exposed a bug in edit links: Such links
+ were titlepage escaped in the urls, and then doubly escaped by the CGI
+ when editing. To fix this, I removed the titlepage escaping in the edit
+ urls.
+ * That means that *every edit link* on the wiki is potentially changed.
+ Rebuilding wikis on upgrade to this version therefore necessary; enabled
+ that in postinst.
+ * Correct a deadlock that could occur in post-commit if the aggregate plugin
+ was enabled and tried to lock the already locked wiki.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 10 Mar 2007 21:11:05 -0500
+
+ikiwiki (1.44) unstable; urgency=low
+
+ * Patch by Ben to fix validaton of atom feeds by fixing the category tags.