+ [ Amitai Schlair ]
+ * meta test: Add tests for many behaviors of the directive.
+ * img test: Bail gracefully when ImageMagick is not present.
+ * meta: Fix [[!meta name=foo]] by closing the open quote.
+ * Avoid unescaped "{" in regular expressions
+
+ [ Joey Hess ]
+ * emailauth: Added emailauth_sender config.
+ * Modified page.tmpl to to set html lang= and dir= when
+ values have been specified for them, which the po plugin does.
+
+ [ Simon McVittie ]
+ * Run autopkgtest tests using autodep8 and the pkg-perl team's
+ infrastructure
+ * t/img.t: do not spuriously skip
+ * tests: consistently use done_testing instead of no_plan
+ * Wrap and sort control files (wrap-and-sort -abst)
+ * Add enough build-dependencies to run all tests, except for
+ non-git VCSs
+ * debian/copyright: update for the rename of openid-selector to
+ login-selector
+
+ -- Simon McVittie <smcv@debian.org> Mon, 15 Jun 2015 18:13:23 +0100
+
+ikiwiki (3.20150614) unstable; urgency=medium
+
+ * inline: change default sort order from age to "age title" for
+ determinism, partially fixing deterministic build for git-annex,
+ ikiwiki-hosting etc. (Closes: #785757)
+ * img: avoid ImageMagick misinterpreting filenames containing a colon
+ * img test: set old timestamp on source file that will change, so that
+ the test will pass even if it takes less than 1 second
+
+ -- Simon McVittie <smcv@debian.org> Sun, 14 Jun 2015 18:13:23 +0100
+
+ikiwiki (3.20150610) unstable; urgency=low
+
+ [ Joey Hess ]
+ * New emailauth plugin lets users log in, without any registration,
+ by simply clicking on a link in an email.
+ * Re-remove google from openid selector; their openid provider is
+ gone for good.
+ * Make the openid selector display "Password" instead of "Other"
+ when appropriate, so users are more likely to click on it when
+ they don't have an openid.
+ * Converted openid-selector into a more generic loginselector helper
+ plugin.
+ * passwordauth: Don't allow registering accounts that look like openids.
+ * Make cgiurl output deterministic, not hash order. Closes: #785738
+ Thanks, Daniel Kahn Gillmor
+
+ [ Simon McVittie ]
+ * Do not enable emailauth by default, to avoid surprises on httpauth-only
+ sites. Enable it by default in openid instead, since it is essentially
+ a replacement for OpenIDs.
+ * Make the attachment plugin work with CGI.pm 4.x (Closes: #786586;
+ workaround for #786587 in libcgi-pm-perl)
+ * Add a public-domain email icon from tango-icon-theme
+ * Populate pagectime from either mtime or inode change time,
+ whichever is older, again for more reproducible builds
+ * debian: build the docwiki with LC_ALL=C.UTF-8 and TZ=UTC
+ * debian/copyright: consolidate permissive licenses
+ * debian/copyright: turn comments on provenance into Comment
+ * brokenlinks: sort the pages that link to the missing page, for
+ better reproducibility
+ * Add [[!meta date]] to news items and tips, since the git checkout
+ and build process can leave the checkout date in the tarball
+ release, leading to unstable sorting
+ * Sort backlinks deterministically, by falling back to sorting by href
+ if the link text is identical
+ * Add a $config{deterministic} option and use it for the docwiki
+ * haiku: if deterministic build is requested, return a hard-coded haiku
+ * polygen: if deterministic build is requested, use a well-known random seed
+
+ -- Simon McVittie <smcv@debian.org> Wed, 10 Jun 2015 21:56:36 +0100
+
+ikiwiki (3.20150329) experimental; urgency=high
+
+ [ Joey Hess ]
+ * Fix NULL ptr deref on ENOMEM in wrapper. (Thanks, igli)
+
+ [ Simon McVittie ]
+ * Really don't double-decode CGI submissions, even on Perl versions that
+ bundle an old enough Encode.pm for that not to be a problem: the
+ system might have a newer Encode.pm installed separately, like Fedora 20.
+ (Closes: #776181; thanks, Anders Kaseorg)
+ * If neither timezone nor TZ is set, set both to :/etc/localtime if
+ we're on a GNU system and that file exists, or GMT otherwise
+ * t/inline.t: accept translations of "Add a new post titled:"
+ (Closes: #779365)
+ * Consistently document command-line options as e.g. --refresh, not -refresh
+
+ [ Amitai Schlair ]
+ * In VCS-committed anonymous comments, link to url.
+
+ [ Joey Hess ]
+ * Fix XSS in openid selector. Thanks, Raghav Bisht. (Closes: #781483)
+
+ -- Simon McVittie <smcv@debian.org> Sun, 29 Mar 2015 21:48:24 +0100
+
+ikiwiki (3.20150107) experimental; urgency=medium
+
+ [ Joey Hess ]