]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
3.20160728
[git.ikiwiki.info.git] / debian / rules
index 0a65715214cf2464dc021bc820de3f5bf049a1f6..cf3087d1db711dc46539c908742b1983f2b70967 100755 (executable)
@@ -1,19 +1,15 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       LC_ALL=C.UTF-8 TZ=UTC dh $@
 
-# keeps it out if /usr/local
 override_dh_auto_configure:
+       # keeps it out of /usr/local
        dh_auto_configure -- PREFIX=/usr
 
-# avoid compressing files in the doc wiki
 override_dh_compress:
+       # avoid compressing files in the doc wiki
        dh_compress -Xhtml
 
-# distclean moans about MANIFEST, this is quieter
 override_dh_auto_clean:
-       $(MAKE) realclean
-
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/ikiwiki/doc/news
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi