+ikiwiki (2.69) UNRELEASED; urgency=low
+
+ * aggregate: Try to query XML::Feed for the base url when derelevatising
+ links. Since this needs the just released XML::Feed 0.3, as well
+ as a not yet released XML::RSS, it will fall back to the old method
+ if no xml:base info is available.
+ * meta: Plugin is now enabled by default since the basewiki uses it.
+ * txt: Do not encode quotes when filtering the txt, as that broke
+ later parsing of any directives on the page.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 06 Nov 2008 16:01:00 -0500
+
+ikiwiki (2.68) unstable; urgency=low
+
+ * Add support for checking pushes from untrusted git committers. This can be
+ used to set up anonymous git pushes, and other similar things.
+ * format: New plugin, allows embedding differently formatted text inside a
+ page (ie, otl inside a mdwn page, or syntax highlighted code inside a
+ page).
+ * relativedate: New javascript-alicious plugin that makes all dates display
+ relative, in a very nice way, if I say so myself.
+ * Optimise the no-op post-commit hook, to speed up web edits by a fraction
+ of a second.
+ * git: Allow [[sha1_commit]] to be used in the diffurl, to support cgit.
+ * shortcut: Fix display of shortcuts while previewing.
+ * Plugins that used to override displaytime should instead override
+ formattime. displaytime will call that, and may wrap markup around the
+ formatted time.
+ * Add an underlay for javascript, and add ikiwiki.js containing some utility
+ code.
+ * toggle: Stop embedding the full toggle code on each page using it, and
+ move it to toggle.js in the javascript underlay.
+ * recentchanges: Make feed links point back to anchors on the recentchanges
+ page. (JasonBlevins)
+ * Fix issue with utf-8 in wikiname breaking session cookies, by
+ entity-encoding the wikiname in the session cookie.
+ * Use the pure perl Data::Dumper when generating setup files to ensure that
+ utf-8 characters are written out as such, and not as the encoded perl
+ strings the C Data::Dumper produces.
+ * inline: Only the last feed link was put on the page, fix this to include
+ all feed links. So rss will be included along with atom, and pages with
+ multiple feeds will get links added for all feeds.
+ * tag: When tagpage is set, force the links created by tagging to point at
+ the toplevel tagpage, and not closer subpages. The html links already went
+ there, but internally the links were not recorded as absolute, which could
+ cause confusing backlinks etc.
+ * Add an inject function, that can be used by plugins that want to
+ replace one of ikiwiki's functions with their own version.
+ (This is a scary thing that grubs through the symbol table, and replaces
+ all exported occurances of a function with the injected version.)
+ * external: RPC functions can be injected to replace exported functions.
+ * Updated French translation. Closes: #502694
+ * Updated Spanish translation from the ever vigilant Victor Moral.
+ * Updated Danish translation from Jonas Smedegaard. Closes: #503117
+ * Preserve syslog setting when doing `ikiwiki -setup foo -dumpsetup bar`
+ * Several fixes to --render mode.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 03 Nov 2008 16:31:11 -0500
+
+ikiwiki (2.67) unstable; urgency=low
+
+ * remove: Avoid $_ breakage. (Stupid, stupid perl.)
+ * Updated Spanish translation from Victor Moral.
+ * lockedit: Support specifying which users (and IP addresses) a page
+ is locked for. This supports most of the ACL type things users have been
+ wanting to be done. Closes: #443346 (It does not control who can read a
+ page, but that's out of scope for ikiwiki.)
+ * orphans: Fix unquoted page name in regexp.
+ * google: Plugin provides google site search, contributed by Peter Simons.
+ * Pass HTTPS variable through the wrapper so that CGI->https can be used
+ by plugins. Closes: #502047
+ * inline: Allow MTIME to be used in inlinepage.tmpl.
+ * inline: Use the feed's description in the rss and atom links.
+ Closes: #502113
+ * aggregate: Avoid bug that caused immediate expiration of items
+ with a date in the future.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 17 Oct 2008 13:13:41 -0400
+
+ikiwiki (2.66) unstable; urgency=low
+
+ * recentchanges: Fix redirects to non-page files.
+ * aggregate: Avoid uninitialized value warnings for pages with no recorded
+ ctime.
+ * attachment: Add admin() pagespec to test if the uploading user is a wiki
+ admin.
+ * git: Fix handling of utf-8 filenames in recentchanges.
+ * tag: Make edit link for new tags ensure that the tags are created
+ inside tagbase, when it's set.
+ * template: Make edit link for new templates ensure the page is located
+ under toplevel templates directory.
+ * htmlscrubber: Add a config setting that can be used to disable the
+ scrubber acting on a set of pages.
+ * Expand usage message and add --help. Closes: #500344
+ * Beautify urls used in various places. (smcv)
+ * Export pagetitle, titlepage, linkpage.
+ * htmltidy: Avoid returning undef if tidy fails. Also avoid returning the
+ untidied content if tidy crashes. In either case, it seems best to tidy
+ the content to nothing.
+ * htmltidy: Avoid spewing tidy errors to stderr.
+ * Reorganize index file, add a format version field. Upgrades to the new
+ index format should be transparent.
+ * Add %wikistate, which is like %pagestate except not specific to a given
+ page, and is preserved across rebuilds.
+ * editpage: Be more aggressive (and less buggy) about cleaning up
+ temporary files rendered during page preview.
+ * Add an indexpages option, which causes foo/index.mdwn to be the source
+ for page foo when foo.mdwn doesn't exist. Also, when it's enabled,
+ creating a new page will save it to foo/index.mdwn by default.
+ Closes: #474611
+ (Sponsored by The TOVA Company.)
+ * httpauth: Document that ikiwiki.cgi has to be in a directory subject to
+ authentication. Closes: #500524
+ * inline: Fix handling of rootpage that doesn't exist.
+ * attachment: Support adding attachments to pages even as they are being
+ created.
+ * remove, rename: Allow acting on attachments as a page is being created.
+ * Updated French translation. Closes: #500929