]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
hablar sobre sistemas operativos UNIVERSALES ES LO MEJOR
[git.ikiwiki.info.git] / debian / rules
index da8249920a4daa0208c3e9cf7098ba7b1b5a00fa..9cb2a8adc3af0549830b0bbe57dd61a5a3740c43 100755 (executable)
@@ -1,14 +1,15 @@
 #!/usr/bin/make -f
-
-binary: binary-indep
-binary-indep:
-       dh $@ --before dh_compress
-       dh_compress -Xhtml
-       dh $@ --after dh_compress
-
 %:
        dh $@
 
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/ikiwiki/doc/news
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
+
+override_dh_compress:
+       # avoid compressing files in the doc wiki
+       dh_compress -Xhtml
+
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi