#!/usr/bin/make -f
+%:
+ LC_ALL=C.UTF-8 TZ=UTC dh $@
-binary: binary-indep
-binary-indep:
- dh $@ --before dh_compress
- dh_compress -Xhtml
- dh $@ --after dh_compress
+override_dh_auto_configure:
+ # keeps it out of /usr/local
+ dh_auto_configure -- PREFIX=/usr
-%:
- dh $@
+override_dh_compress:
+ # avoid compressing files in the doc wiki
+ dh_compress -Xhtml
-# Not intended for use by anyone except the author.
-announcedir:
- @echo ${HOME}/src/ikiwiki/doc/news
+override_dh_auto_clean:
+ # distclean moans about MANIFEST, this is quieter
+ if [ -e Makefile ]; then $(MAKE) realclean; fi