]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
3.20160728
[git.ikiwiki.info.git] / debian / rules
index da8249920a4daa0208c3e9cf7098ba7b1b5a00fa..cf3087d1db711dc46539c908742b1983f2b70967 100755 (executable)
@@ -1,14 +1,15 @@
 #!/usr/bin/make -f
+%:
+       LC_ALL=C.UTF-8 TZ=UTC dh $@
 
-binary: binary-indep
-binary-indep:
-       dh $@ --before dh_compress
-       dh_compress -Xhtml
-       dh $@ --after dh_compress
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
 
-%:
-       dh $@
+override_dh_compress:
+       # avoid compressing files in the doc wiki
+       dh_compress -Xhtml
 
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/ikiwiki/doc/news
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi