+ * Centralised all calls to HTML::Template and force all the templates
+ to be read as utf8.
+ * Support pages with utf8 filenames. Patch by Faidon Liambotis.
+ * Introduce add_plugins and disable_plugins config options in setup files.
+ This allows adding or removing plugins w/o overriding the whole list of
+ default plugins, which makes it easier to upgrade when new default plugins
+ are added.
+ * Support htmlize plugins and make mdwn one such plugin, which is enabled by
+ default (of course!). Based on a patch by Faidon Liambotis.
+ * Add a html plugin, which can be used to write wikis in raw html,
+ if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
+ defaults to not processing .html files, since w/o this plugin they would
+ be copied unsanitised. With this plugin, it will process and html
+ sanitise them, like any other page type.
+ * Rebuilding wrappers is necessary on upgrade to this version.
+ * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
+ will be automatically done on all upgrades.
+ * Don't send pings if the wiki is being rebuilt.
+ * Work around very innefficient behavior in File::Spec::abs2rel. Result
+ is a savings of 2 pointless fork/execs per link calculation, which
+ results in ~25% speedup of ikiwiki building its own doc wiki, and
+ about 35% speedup displaying RecentChanges!
+ * Make RecentChanges use a table and some CSS, should be much more readable.
+ No code changes involved.
+ * Encode & in diffurl in examples, to conform to pedantic rules.
+ * Speed up RecentChanges by another 40% or so with some memoization.
+ * Memoize abs2rel, which is still kinda slow, for another 30% speedup
+ in time to build the doc wiki.