+ikiwiki (2.2) UNRELEASED; urgency=low
+
+ * Change the aggregate plugin's locking strategy. Now it defers loading state
+ until the wiki is building and already locked, unless it's aggregating.
+ When aggregating, it does not wait for the lock if it cannot get it, and
+ instead exits, to prevent aggregating processes from piling up.
+ * Updated Spanish translation from Victor Moral.
+ * Correct bug in the img plugin that caused dependencies on images to not
+ always be tracked correctly.
+ * Deal better with rebuilds that involve moving files; track and clean up the
+ old files.
+ * Change where the img plugin puts scaled images. It's better to make the
+ scaled images subpages of the page that embeds them, rather than putting
+ them alongside the original image, since if two pages scale the same image
+ the same way, this prevents complications in dealing with two pages
+ creating the same file. The move will be handled transparently, though you
+ might want to rebuild your wiki to make it occur in one step.
+ * Fix FTBFS in test suite introduced in last version. Closes: #425891
+ * Apply a patch from Carl Worth allowing a class attribute to be passed
+ through the img plugin. Also allow the id attribute to be passed through.
+ * More consistent encoding of titles in rss and atom feeds. Don't use
+ ESCAPE=HTML for titles in the templates for these feeds, and instead
+ escape the title going in to the template. Previously, the title was
+ sometimes double-escaped in a feed (if set via meta title), and sometimes
+ not (if set from the page filename).
+ * In the meta plugin, when a title is set, encode the html entities in it
+ numerically. This works better in the current landscape of a rss spec that
+ doesn't specify encoding, and variously broken feed consumers, according
+ to <http://www.rssboard.org/rss-profile#data-types-characterdata>.
+ * Correct some issues with display of unhandled preprocessor directives.
+ * Apply a patch from Carl Worth adding support for using globs in link()
+ in a PageSpec.
+ * Explode some of the more insane regexps.
+ * Add test suite for preprocessor directive parsing.
+ * Fix wrapper generator and untaint code's handling of strings contining
+ newlines.
+ * Make the url absolution code for feeds significantly more robust.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 03 Jun 2007 13:10:08 -0400
+
+ikiwiki (2.1) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Use div layout for the signin and preferences forms, so that they can be
+ styled using the stylesheet, rather than by creating signin and prefs
+ templates.
+ * Make the openid login form nicely styled.
+ * Fix a bug that prevented clearing email or subscriptions.
+ * Improve handling of edits of locked pages by users who are not yet signed
+ in.
+ * Make testpagespec more robust, including checking for missing/bad
+ parameters.
+ * Add all=no option to conditional, can be used to form conditionals that do
+ not need to examine every page in the wiki.
+ * Add the needsbuild hook. Plugins can use this to manipulate which files
+ ikiwiki builds when refreshing the wiki.
+
+ [ Josh Triplett ]
+ * Add an account-creation password as a simple anti-spam mechanism. If
+ set in the wiki setup, passwordauth will require the password in
+ order to create an account.
+
+ [ Joey Hess ]
+ * Updated Czech translation from Miroslav Kure.
+ * Apply patch from Pawel to avoid using -L in Makefile as it's not available
+ in older finds.
+ * Make all templates have a footer div to ease themeing. Required template
+ and style sheet updates, and unless you're using customised versions,
+ you'll want to rebuild wikis on upgrade to this version to avoid
+ inconsistencies.
+ * Allow WIKINAME to to used in footers, as an example of something to put
+ there.
+ * Patch from hb to fix the pagestats plugin, which was broken by a past
+ change to the backlinks() function.
+ * Fix some bugs in password handling:
+ - If the password is empty in preferences, don't clear the existing
+ password.
+ - Actually check the confirm password field, even if it's left empty.
+ * Add a destpage parameter to the filter hook.
+ * Fix links to smilies generated by the smiley plugin for inlined pages. The
+ old links were often wrong, but often still worked by accident.
+ * Add a test ensuring that the basewiki is self-contained and has no broken
+ links.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 19 May 2007 20:37:38 -0400
+
+ikiwiki (2.00) unstable; urgency=low
+
+ [ Josh Triplett ]
+ * Avoid using GNU extensions to cp during "make install", which did
+ not work on FreeBSD. Thanks to Henrik Brix Andersen for the patch.
+
+ [ Joey Hess ]
+ * Use fieldsets in the preferences form to group related options together.
+ Especially cleans up the ordering of the admin's preferences form.
+ * Use a fieldset to set off the openid entry from the rest of the login
+ form.
+ * Enable openid logins by default.
+ * Enable usedirs by default.
+
+ [ Josh Triplett ]
+ * fieldset support appeared in CGI::FormBuilder 3.05, so increase
+ version in Depends on libcgi-formbuilder-perl to 3.05
+
+ [ Joey Hess ]
+ * If Net::OpenID::Consumer is not available, the openid module will quietly
+ disable itself, this avoids needing a hard dependency on the perl module.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 30 Apr 2007 00:43:02 -0400
+
+ikiwiki (1.51) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Support setting svnpath to "" for wikis that are rooted at the top of
+ their svn repositories, with no trunk directory.
+ * Minor template improvements by Alessandro.
+ * In mercurial backend, untaint ipaddr when using it as the user for the
+ commit. Thanks, Alexander Wirt. Closes: #420428
+ * Fix aggregator to not warn when a feed contains no body content at all.
+ * Work around bug #420636 by, if XML::Parser crashes, running the feed
+ content though Encode::decode_utf8.
+
+ [ Josh Triplett ]
+ * Change basewiki CSS to not put a border around images used as links.
+
+ [ Joey Hess ]
+ * Move the footer div to enclose tags and links too.
+ * More style sheet updates, remove the hack that used the tags div to create
+ the footer border.
+ * Due to template changes and style sheet changes that depend on them,
+ wiki rebuilds are recommended on upgrade to this version.
+ * Avoid .svn directories when installing from svn checkout.
+ * Fix sending of commit mails when new pages are added via the web.
+ * Add user(name) to the PageSpec for commit subscriptions.
+ * pagespec_match() has changed to take named parameters, to better allow
+ for extended pagespecs. The old calling convention will still work for
+ back-compat for now.
+ * The calling convention for functions in the IkiWiki::PageSpec namespace
+ has changed so they are passed named parameters.
+ * Plugin interface version increased to 2.00 since I don't anticipate any
+ more interface changes before 2.0.
+ * Updated Gujarati translation from Kartik Mistry. Closes: #421198
+ * Make pagespec_match return an object that can be stringified to tell
+ the reason why the match failed or succeeded.
+ * Add testpagespec plugin, which might be useful to see why a pagespec isn't
+ working as desired.
+
+ [ Josh Triplett ]
+ * Fix bestlink to use pagecase for pages in userdir, to support pages
+ with non-lowercase filenames.
+
+ [ Joey Hess ]
+ * Include wikiname in syslogged messages.
+ * Updated Polish translation from Pawel Tecza.
+ * Updated Czech translation from Miroslav Kure.
+ * Updated Spanish translation from Victor Moral.
+ * Apply patch from hb that uses the full path to a file when adding a file
+ using the mercurial backend. Not 100% sure why it failed w/o the full
+ path, but this still passes the test suite, and indeed, is how the test
+ suite calls hg add.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 29 Apr 2007 00:01:23 -0400
+
+ikiwiki (1.50) unstable; urgency=low
+
+ [ Josh Triplett ]
+ * Add a graphviz plugin.
+ * Suggests: graphviz
+ * Enhance helponformatting and related documentation to supply more
+ information about available preprocessor directives.
+ * Add myself as a co-maintainer, with Joey's approval.
+
+ [ Joey Hess ]
+ * Add support for PROFILE=1 to the Makefile, this turns on profiling of the
+ wiki build using Devel::Profiler (Dprof can't handle ikiwiki).
+ * Add a new %destsources hash, which maps between a destination file and
+ the source page used to create it, ie it's the reverse of %renderedfiles.
+ * Use %destsources in htmllink and urlto for 20-50% speedup. Thanks
+ Josh Triplett for the idea.
+ * Optimise displaytime, trimming maybe 6% off the build time.
+
+ [ Josh Triplett ]
+ * Conflicts/Replaces/Provides the unofficial ikiwiki-plugin-table
+ package, because ikiwiki now provides the table plugin, and thus has
+ a file overlap with ikiwiki-plugin-table.
+ * Add libtext-csv-perl to Suggests, for the table plugin.
+ * Add libdigest-sha1-perl to Suggests, for sparkline and graphviz.
+ * Add libtext-typography-perl to Suggests for the typography plugin.
+
+ [ Joey Hess ]
+ * Add postformtext parameter to inline.
+ * Internal version number and installdir substitutions were lost, fix.
+ * Apply patch from Ethan to improve an error message that should never
+ happen.
+ * Patch from Tuomov to link to the directory in feeds when usedirs is in
+ effect. Note that this changes permalinks, so if you are already using
+ usedirs you'll have to deal with that on upgrade to this version.
+ * Add feedshow parameter to inline, which can be useful for eg, removing
+ old posts from feeds when permalinks change.
+ * Add .dpkg-tmp to prune regexp, so that if ikiwiki is run right as it's
+ being upgraded by dpkg it will ignore dpkg temp files in the basewiki.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 15 Apr 2007 16:02:05 -0400
+
+ikiwiki (1.49) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Add --post-commit option, which allows for the case of a split web server
+ and RCS server (or a push mirror). With this the RCS server can have a
+ real post-commit hook that sshs back to the web server, and runs ikiwiki
+ in post-commit mode to update the wiki.
+ * Fix urls generated by mirrorlist plugin.
+ * Add a templates page to the basewiki. It will automatically list all
+ available templates. Rename the old templates page to wikitemplates.
+ * Include the note template in the basewiki.
+ * Add a popup template in the basewiki. CSS based on some by Martin Krafft.
+ * Make the note, popup, and plugin templates detect missing variables and be
+ self-documenting, listing the available variables.
+ * Hide excess backlinks and expand using CSS trick; control quantiy via
+ the numbacklinks setting.
+ * Finally apply the index.html patch, with thanks to everyone who worked
+ on and supported creating it (especially Tuomov). This adds a "usedirs"
+ option that makes ikiwiki use foo/index.html instead of foo.html as
+ output page names. It is not yet enabled by default.
+ * Fix a bug in the img plugin that caused thumbnailed files to not be
+ tracked properly.
+ * Make the OpenID library a reccommendation of the Debian package, rather
+ than just a suggests, since OpenID is enabled by default.
+ * Fix a bug that caused link(foo) to succeed if page foo did not exist.
+ * Fix tags to page names that contain special characters.
+
+ [ Josh Triplett ]
+ * Use pngcrush and optipng on all PNG files.
+ * Add neutral smileys ":|" and ":-|", and question icon smiley "(?)",
+ with images taken from phpBB (GPL) and converted with gif2png.
+ * Improvements to Description in debian/control:
+ * Note that some plugins have additional dependencies, found among the
+ Recommends and Suggests.
+ * ikiwiki supports both RSS and Atom feeds.
+ * Fix typos.
+ * Add Homepage field.
+ * Add XS-Vcs-Browser field.
+
+ [ Joey Hess ]
+ * Updated French translation from JLC. Closes: #417982
+ * Reorder the icon in the template above the stylesheets, to avoid icon
+ flashing during page load.
+ * Fix smiley plugin to scan smileys.mdwn after it's updated, which fixes
+ a bug caused by committing changes to smilies.mdwn.
+ * Fix display of escaped wikilinks containing anchors.
+
+ [ Josh Triplett ]
+ * Remove stray semicolon in linkmap.pm.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 08 Apr 2007 16:14:46 -0400
+
+ikiwiki (1.48) unstable; urgency=low
+
+ * Fix link() PageSpecs to not just look at the raw link text, but at where
+ that given link points based on the page doing the linking. Note that this
+ could make such PageSpecs match different things than before, if you
+ relied on the old behavior of them only matching the raw link text.
+ * This required changing the match_* interface, adding a third parameter.
+ * Allow link() PageSpecs to match relative, as is allowed with globs.
+ * Add postform option to inline plugin.
+ * Add an bug tracker to the softwaresite example.
+ * Make ikiwiki's stylesheet support printing by hiding parts of the page
+ that shouldn't appear in a printout: Search box, actions bar,
+ blog post form, tags, backlinks, and feed buttons.
+ * Finally fixed the longstanding inline removal bug.
+ * Renamed %oldpagemtime to a more accurately named %pagemtime and fix it to
+ actually store pages' mtimes.
+ * Add "mtime" sort parameter to inline plugin.
+ * Fix mercurial backend to deal with empty commit messages.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 24 Mar 2007 11:14:10 -0400
+
+ikiwiki (1.47) unstable; urgency=low
+
+ * Fix a security hole that allowed insertion of unsafe content via the meta
+ plugins's support for inserting html link and meta tags. Now such content
+ is passed through the htmlscrubber like everything else.
+ * Unfortunatly, that means that some valid uses of those tags are no longer
+ usable, and special case methods needed to be added for including
+ stylesheets, and for doing openid delegation. If you use either of these
+ in your wiki, it will need to be modified. See the meta plugin docs
+ for details.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Mar 2007 14:05:00 -0400
+
+ikiwiki (1.46) unstable; urgency=low
+
+ * Fix a bug with inlined create page links, including Discussion links on
+ blog post pages. The links will now create pages relative to the page that
+ actually contains the link.
+ * French update. Closes: #414597
+ * Fix some broken logic in cgi creation of a subpage when a toplevel page
+ with the same name already exists, and generally simplify the edit code.
+ * Make ikiwiki -verbose -setup with a setup file that enabled syslog logging
+ output the verbose build log to stdout, rather than to the syslog.
+ * Detect the case of two people independently creating the same page at the
+ same time, and let the second person resolve the conflict.
+ * Applied a patch from MichaĆ to make the mercurial backend pass --quiet to
+ hg.
+ * Fix a security hole that allowed a web user to insert arbitrary html in
+ the title of a page due to missing escaping of titles in the meta plugin.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Mar 2007 01:51:30 -0400
+
+ikiwiki (1.45) unstable; urgency=low