-ikiwiki (2.4) UNRELEASED; urgency=low
+ikiwiki (2.7) UNRELEASED; urgency=low
+
+ [ Joey Hess ]
+ * Add an editcontent hook.
+ * Support for looking in multiple directories for underlay files.
+ * Plugins can add new directories to the search path with the add_underlay
+ function.
+ * Split out smiley underlay files into a separate underlay, so if the plugin
+ isn't used, the wiki isn't bloated with all those files.
+ * Allow -cgi -wrapper to be passed on the command line to generate a
+ wrapper.
+ * Fix some taint issues with generating wrappers using the command line.
+ * Don't allow newlines in link text in a wikilink.
+ * Tables containing links with a link text were misparsed, because the "|"
+ in the wikilink looked like a table field separator. Avoid this ambiguity
+ by linkifying the data before parsing it as a table.
+ * Turn on allow_loose_quotes in the table plugin's Text::CSV object,
+ so that links from wikilinks don't confuse the parser.
+ * mercurial: Pass --style default to hg log to ensure right format is used.
+ * mercurial: Fix rcs_getctime (thanks, bma)
+
+ [ Josh Triplett ]
+ * Use git-log rather than the shell, git-rev-list, and git-diff-tree.
+ Patch by Jamey Sharp <jamey@minilop.net>.
+ * Renames from git-diff-tree aren't handled, so don't ask for them.
+ Patch by Jamey Sharp
+ * Handle operating in sub-trees of a git repository.
+ When looking for git commits that affect the wiki, only include changes
+ that affect the ikiwiki source directory. If that is not the top-level
+ directory in this git repository, strip off the prefix as given by
+ `git-rev-parse --show-prefix` from all names reported by git-log.
+ Patch by Jamey Sharp
+
+ -- Joey Hess <joeyh@debian.org> Tue, 28 Aug 2007 22:15:52 -0400
+
+ikiwiki (2.6.1) unstable; urgency=low
+
+ * Ye olde brown paper bag.
+ * Fix minor bug when blogging by cgi, introduced in last version.
+ * Fix a bug in unlockwiki intorduced last version that made it crash ikiwiki
+ if it wasn't locked when called. This is known to break post-commit
+ emails.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 26 Aug 2007 13:38:23 -0400
+
+ikiwiki (2.6) unstable; urgency=low
+
+ * Various minor bug fixes for silly mistakes in the code, thanks to the
+ various reviewers.
+ * Fix problems with previewing in the graphviz plugin. Thanks,
+ HenrikBrixAndersen.
+ * Allow raw html in the rst plugin.
+ * Add --set-option command line switch.
+ * pagetemplate: don't display template name
+ * Add rel=tag attribute to tag links, supporting that microformat, as well
+ as allowing them to be styled specially. Thanks, NicolasLimare.
+ * Add sessioncgi hook.
+ * Move blog form code out of CGI.pm and into the inline plugin.
+ * Updated Spanish translation from Victor Moral.
+ * Updated French translation from Cyril Brulebois. Closes: #437181
+ * The toc directive doesn't work well or make sense inside an inlined page.
+ Disable it when the page with the toc is nested inside another page.
+ * Apply a patch from NicolasLimare adding modification date tags to rss and
+ atom feeds, and also changing the publication time for a feed to the
+ newest modiciation time (was newest creation time).
+ * The patch also adds dcterms:creator to rss items that have a known author.
+ * Support pagespec "functions" with no parameters, like included() in the
+ conditional plugin.
+ * Add time=mtime option to postsparkline.
+ * Fix --libdir to work at the command line.
+ * Plugins can now be written as standalone external programs, which can
+ be written in any language that can do XML RPC.
+ * Change yet again how unhandled and escaped preprocessor directives are
+ re-output onto the page. Hopefully I finally got it right..
+ * Fix bug in deletion/move during edit code introduced in 1.44. Need to take
+ the underlaydir into account.
+ * Fix bug when editing file from underlaydir, need to rcs_add it even though
+ a page creation isn't occuring.
+ * Various minor fixes and stylistic improvements suggested by Perl::Critic.
+ * Applied Jeremie Koenig's pluggable editpage buttons patch:
+ - add a title to the editpage form;
+ - pass a reference to the list of buttons to the formbuilder_setup
+ hooks, so we can add ours;
+ - relax asumption about the possible submit values (use "Save Page"
+ explicitly);
+ - de-hardcode the submit buttons from the editpage template
+ (This was needed for compatability with a bug in CGI::FormBuilder
+ 3.0401, but ikiwiki already needs a newer version.)
+ * Pass buttons to all other formbuilder_setup hooks too.
+ * Add color parameter to postsparkline. Closes: #438900
+ * Add proper Homepage field to Debian package (needs uber-new dpkg).
+ * Add monotone support, contributed by William Uther.
+ * Avoid ugly gettext messages if LANG is empty. Closes: #439035
+ * Added teximg plugin to generate images from latex code.
+ Contributed by Patrick Winnertz as a GSoC project.
+ * Call the formbuilder hook for the edit page.
+ * Call decode_form_utf8 before running formbuilder_setup hooks.
+ * Add editdiff plugin contributed by Jeremie Koenig.
+ * Fix it to not leak path info.
+ * Add embed plugin, which allows embedding content from google maps, video,
+ calendar, and youtube. Normally, the htmlsanitiser eats these since they
+ use unsafe tags, the embed plugin overrides it for trusted sites.
+ * The googlecalendar plugin is now deprecated, and will be removed
+ eventually. Please switch to using the embed plugin.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 24 Aug 2007 17:09:44 -0400
+
+ikiwiki (2.5) unstable; urgency=low
+
+ * Wrap the editpage template in the standard misctemplate, this allows the
+ pagetemplate hook to work for that page.
+ * Above change fixes the favicon plugin to work on edit pages.
+ * Correct some issues with escaped preprocessor directives.
+ * Make the map plugin notice when pages in the map are deleted and update
+ it.
+ * Add a htmlext config option, this can be used to make ikiwiki generate
+ html files with a different extension.
+ * Fix graphviz plugin to not try to read images as utf-8; they might
+ sometimes contain invalid utf-8 byte sequences. Thanks,
+ HenrikBrixAndersen.
+ * Fix re-rendering of pages when a linked to page goes away. This was broken
+ in version 1.50 with the addition of %destsources. Thanks, Ethan
+ Glasser-Camp.
+ * Add templatefile hook.
+ * Add pagetemplate plugin, which allows changing the template used for
+ a page. (Not to be confused with the hook of the same name..)
+ * Add a libdir config option to let ikiwiki load perl modules, including
+ plugins, from a user-configurable directory.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 26 Jul 2007 21:42:43 -0400
+
+ikiwiki (2.4) unstable; urgency=low
* Make the toc plugin use html-compatible anchors. This is necessary since
most web sites serve ikiwiki xhtml files as text/html and mozilla browsers
* Support building on systems that lack asprintf.
* mercurial getctime is currently broken, apparently by some change in
mercurial version 0.9.4. Turn the failing test case into a TODO test case.
-
- -- Joey Hess <joeyh@debian.org> Wed, 11 Jul 2007 12:23:41 -0400
+ * Fix links to alternate stylesheets when usedirs is enabled. Closes: #432556
+ * Use type= not style= in html for alternate stylesheets, which is more
+ correct (but in my testing both epiphany and iceweasel work ok with
+ style=text/css).
+ * In img tag, allow link=no to disable link to full size image. Thanks,
+ Nis Martensen. Closes: #433188
+
+ -- Joey Hess <joeyh@debian.org> Sun, 15 Jul 2007 15:02:43 -0400
ikiwiki (2.3) unstable; urgency=low